What’s Vulnerable › Vulnerabilities
CVE-2021-4134: Fancy Product Designer <= 4.7.4 Admin+ SQL Injection
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-16 · updated 2026-06-17
- Weakness: CWE-89
Description
The Fancy Product Designer WordPress plugin is vulnerable to SQL Injection due to insufficient escaping and parameterization of the ID parameter found in the ~/inc/api/class-view.php file which allows attackers with administrative level permissions to inject arbitrary SQL queries to obtain sensitive information, in versions up to and including 4.7.4.
Affected products
- radykal Fancy Product Designer: before 4.7.5 — fixed in 4.7.5
How to fix
Upgrade to a fixed version: radykal Fancy Product Designer 4.7.5. Check the vendor advisory for mitigations.
References
- https://support.fancyproductdesigner.com/support/discussions/topics/13000031264
- https://www.wordfence.com/vulnerability-advisories/#CVE-2021-4134
- https://support.fancyproductdesigner.com/support/discussions/topics/13000031264
- https://www.wordfence.com/vulnerability-advisories/#CVE-2021-4134
Get alerted when CVE-2021-4134 or the next vulnerability affects your stack