What’s Vulnerable › Vulnerabilities
CVE-2021-41387
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-17 · updated 2026-06-17
- Weakness: CWE-426
Description
seatd-launch in seatd 0.6.x before 0.6.2 allows privilege escalation because it uses execlp and may be installed setuid root.
Affected products
- Seatd Project Seatd: from 0.6.0 before 0.6.2 — fixed in 0.6.2
How to fix
Upgrade to a fixed version: Seatd Project Seatd 0.6.2. Check the vendor advisory for mitigations.
References
- https://lists.sr.ht/~kennylevinsen/seatd-announce/%3CGJ2IZQ.HCKS1J0LSI803%40kl.wtf%3E
- https://lists.sr.ht/~kennylevinsen/seatd-announce/%3CGJ2IZQ.HCKS1J0LSI803%40kl.wtf%3E
Get alerted when CVE-2021-41387 or the next vulnerability affects your stack