What’s Vulnerable › Vulnerabilities
CVE-2021-4139: Cross-site Scripting (XSS) - Stored in pimcore/pimcore
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-21 · updated 2026-06-17
- Weakness: CWE-79
Description
pimcore is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- pimcore/pimcore: before 10.2.7 — fixed in 10.2.7
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.2.7. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/d5c3e876d910784000335061c3bd24d301351245
- https://huntr.dev/bounties/6ec59e43-095f-4ba3-8b75-e92250da8e3a
- https://github.com/pimcore/pimcore/commit/d5c3e876d910784000335061c3bd24d301351245
- https://huntr.dev/bounties/6ec59e43-095f-4ba3-8b75-e92250da8e3a
Get alerted when CVE-2021-4139 or the next vulnerability affects your stack