What’s Vulnerable › Vulnerabilities
CVE-2021-41411
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-16 · updated 2026-06-17
- Weakness: CWE-611
Description
drools <=7.59.x is affected by an XML External Entity (XXE) vulnerability in KieModuleMarshaller.java. The Validator class is not used correctly, resulting in the XXE injection vulnerability.
Affected products
- RedHat Drools: before 7.6.0 — fixed in 7.6.0
How to fix
Upgrade to a fixed version: RedHat Drools 7.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-41411 or the next vulnerability affects your stack