What’s Vulnerable › Vulnerabilities
CVE-2021-41558
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-27 · updated 2026-06-17
Description
The set_user extension module before 3.0.0 for PostgreSQL allows ProcessUtility_hook bypass via set_config.
Affected products
- Set User Project Set User: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Set User Project Set User 3.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/pgaudit/set_user/releases/tag/REL3_0_0
- https://github.com/pgaudit/set_user/releases/tag/REL3_0_0
Get alerted when CVE-2021-41558 or the next vulnerability affects your stack