What’s Vulnerable › Vulnerabilities
CVE-2021-41571: Pulsar Admin API allows access to data from other tenants using getMessageById API
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-863
Description
In Apache Pulsar it is possible to access data from BookKeeper that does not belong to the topics accessible by the authenticated user. The Admin API get-message-by-id requires the user to input a topic and a ledger id. The ledger id is a pointer to the data, and it is supposed to be a valid it for the topic. Authorisation controls are performed against the topic name and there is not proper validation the that ledger id is valid in the context of such ledger. So it may happen that the user is able to read from a ledger that contains data owned by another tenant. This issue affects Apache Pulsar Apache Pulsar version 2.8.0 and prior versions; Apache Pulsar version 2.7.3 and prior versions; Apache Pulsar version 2.6.4 and prior versions.
Affected products
- Apache Software Foundation Apache Pulsar: from 2.6.0 before 2.6.4; from 2.7.0 before 2.7.3; 2.8.0 — fixed in 2.6.4, 2.7.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 2.6.4, 2.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/apache/pulsar/issues/11814
- https://lists.apache.org/thread/8n3k7pvyh4cf9q2jfzb6pb32ync6xlvr
- https://pulsar.apache.org/admin-rest-api/#operation/getLastMessageId
- https://github.com/apache/pulsar/issues/11814
- https://lists.apache.org/thread/8n3k7pvyh4cf9q2jfzb6pb32ync6xlvr
- https://pulsar.apache.org/admin-rest-api/#operation/getLastMessageId
Get alerted when CVE-2021-41571 or the next vulnerability affects your stack