What’s Vulnerable › Vulnerabilities
CVE-2021-41580
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-27 · updated 2026-06-17
Description
The passport-oauth2 package before 1.6.1 for Node.js mishandles the error condition of failure to obtain an access token. This is exploitable in certain use cases where an OAuth identity provider uses an HTTP 200 status code for authentication-failure error reports, and an application grants authorization upon simply receiving the access token (i.e., does not try to use the token). NOTE: the passport-oauth2 vendor does not consider this a passport-oauth2 vulnerability
Affected products
- Passportjs Passport-Oauth2: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: Passportjs Passport-Oauth2 1.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/jaredhanson/passport-oauth2/commit/8e3bcdff145a2219033bd782fc517229fe3e05ea
- https://github.com/jaredhanson/passport-oauth2/compare/v1.6.0...v1.6.1
- https://github.com/jaredhanson/passport-oauth2/pull/144
- https://github.com/jaredhanson/passport-oauth2/commit/8e3bcdff145a2219033bd782fc517229fe3e05ea
- https://github.com/jaredhanson/passport-oauth2/compare/v1.6.0...v1.6.1
- https://github.com/jaredhanson/passport-oauth2/pull/144
Get alerted when CVE-2021-41580 or the next vulnerability affects your stack