What’s Vulnerable › Vulnerabilities
CVE-2021-41588
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-24 · updated 2026-06-17
- Weakness: CWE-502
Description
In Gradle Enterprise before 2021.1.3, a crafted request can trigger deserialization of arbitrary unsafe Java objects. The attacker must have the encryption and signing keys.
Affected products
- gradle: from 2017.2 before 2021.1.3 — fixed in 2021.1.3
How to fix
Upgrade to a fixed version: gradle 2021.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-41588 or the next vulnerability affects your stack