What’s Vulnerable › Vulnerabilities

CVE-2021-41611

Description

An issue was discovered in Squid 5.0.6 through 5.1.x before 5.2. When validating an origin server or peer certificate, Squid may incorrectly classify certain certificates as trusted. This problem allows a remote server to obtain security trust well improperly. This indication of trust may be passed along to clients, allowing access to unsafe or hijacked services.

Affected products

How to fix

Upgrade to a fixed version: Squid 5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-41611 or the next vulnerability affects your stack