What’s Vulnerable › Vulnerabilities
CVE-2021-4170: Cross-site Scripting (XSS) - Stored in janeczku/calibre-web
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
calibre-web is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- janeczku/calibre-web: before 0.6.15 — fixed in 0.6.15
How to fix
Upgrade to a fixed version: janeczku/calibre-web 0.6.15. Check the vendor advisory for mitigations.
References
- https://github.com/janeczku/calibre-web/commit/7ad419dc8c12180e842a82118f4866ac3d074bc5
- https://huntr.dev/bounties/ff395101-e392-401d-ab4f-579c63fbf6a0
- https://github.com/janeczku/calibre-web/commit/7ad419dc8c12180e842a82118f4866ac3d074bc5
- https://huntr.dev/bounties/ff395101-e392-401d-ab4f-579c63fbf6a0
Get alerted when CVE-2021-4170 or the next vulnerability affects your stack