What’s Vulnerable › Vulnerabilities
CVE-2021-4176: Cross-site Scripting (XSS) - Reflected in livehelperchat/livehelperchat
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-29 · updated 2026-06-17
- Weakness: CWE-79
Description
livehelperchat is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- livehelperchat/livehelperchat: before 3.91 — fixed in 3.91
How to fix
Upgrade to a fixed version: livehelperchat/livehelperchat 3.91. Check the vendor advisory for mitigations.
References
- https://github.com/livehelperchat/livehelperchat/commit/1f67cf9f251289a5094774307c2c3d638f9f0ba6
- https://huntr.dev/bounties/8b531ae9-2d36-43ff-af33-4d81acfb2f27
- https://github.com/livehelperchat/livehelperchat/commit/1f67cf9f251289a5094774307c2c3d638f9f0ba6
- https://huntr.dev/bounties/8b531ae9-2d36-43ff-af33-4d81acfb2f27
Get alerted when CVE-2021-4176 or the next vulnerability affects your stack