What’s Vulnerable › Vulnerabilities

CVE-2021-41772

Description

Go before 1.16.10 and 1.17.x before 1.17.3 allows an archive/zip Reader.Open panic via a crafted ZIP archive containing an invalid name or an empty filename field.

Affected products

How to fix

Upgrade to a fixed version: Go 1.16.10, 1.17.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-41772 or the next vulnerability affects your stack