What’s Vulnerable › Vulnerabilities
CVE-2021-4178
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-24 · updated 2026-06-17
- Weakness: CWE-502
Description
A arbitrary code execution flaw was found in the Fabric 8 Kubernetes client affecting versions 5.0.0-beta-1 and above. Due to an improperly configured YAML parsing, this will allow a local and privileged attacker to supply malicious YAML.
Affected products
- RedHat A-Mq Streams: 2.0.1
- Red Hat build of Quarkus: 2.2.5
- RedHat Descision Manager: 7.0
- RedHat Fabric8-Kubernetes: from 5.0.1 before 5.0.3; from 5.1.0 before 5.1.2; from 5.2.0 before 5.3.2; from 5.5.0 before 5.7.4; from 5.9.0 before 5.10.2; from 5.11.0 before 5.11.2 — fixed in 5.0.3, 5.1.2, 5.10.2, 5.11.2, 5.3.2, 5.7.4
- Red Hat Fuse: 7.11
- RedHat Integration Camel K: all versions
- RedHat Integration Camel Quarkus: 2.2.1
- RedHat Openshift Application Runtimes: all versions
- RedHat Process Automation: 7.0
How to fix
Upgrade to a fixed version: RedHat Fabric8-Kubernetes 5.0.3, 5.1.2, 5.10.2, 5.11.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2021-4178
- https://bugzilla.redhat.com/show_bug.cgi?id=2034388
- https://github.com/advisories/GHSA-98g7-rxmf-rrxm
- https://github.com/fabric8io/kubernetes-client/issues/3653
- https://access.redhat.com/security/cve/CVE-2021-4178
- https://bugzilla.redhat.com/show_bug.cgi?id=2034388
- https://github.com/advisories/GHSA-98g7-rxmf-rrxm
- https://github.com/fabric8io/kubernetes-client/issues/3653
Get alerted when CVE-2021-4178 or the next vulnerability affects your stack