What’s Vulnerable › Vulnerabilities
CVE-2021-41784
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-416
Description
Foxit PDF Reader before 11.1 and PDF Editor before 11.1, and PhantomPDF before 10.1.6, allow attackers to trigger a use-after-free and execute arbitrary code because JavaScript is mishandled.
Affected products
- Foxit PDF Reader: from 11.0 before 11.1 — fixed in 11.1
- Foxit Pdf Reader: from 11.0 before 11.1 — fixed in 11.1
- Foxit Phantompdf: before 10.1.6 — fixed in 10.1.6
How to fix
Upgrade to a fixed version: Foxit PDF Reader 11.1; Foxit Pdf Reader 11.1; Foxit Phantompdf 10.1.6. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.foxit.com/support/security-bulletins.html
Get alerted when CVE-2021-41784 or the next vulnerability affects your stack