What’s Vulnerable › Vulnerabilities
CVE-2021-41801
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-11 · updated 2026-06-17
Description
The ReplaceText extension through 1.41 for MediaWiki has Incorrect Access Control. When a user is blocked after submitting a replace job, the job is still run, even if it may be run at a later time (due to the job queue backlog)
Affected products
- Wikimedia Foundation MediaWiki: before 1.31.16; from 1.35.0 before 1.35.4; from 1.36.0 before 1.36.2 — fixed in 1.31.16, 1.35.4, 1.36.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.31.16, 1.35.4, 1.36.2. Check the vendor advisory for mitigations.
References
- https://lists.wikimedia.org/hyperkitty/list/wikitech-l%40lists.wikimedia.org/thread/2IFS5CM2YV4VMSODPX3J2LFHKSEWVFV5/
- https://phabricator.wikimedia.org/T279090
- https://lists.wikimedia.org/hyperkitty/list/wikitech-l%40lists.wikimedia.org/thread/2IFS5CM2YV4VMSODPX3J2LFHKSEWVFV5/
- https://phabricator.wikimedia.org/T279090
Get alerted when CVE-2021-41801 or the next vulnerability affects your stack