What’s Vulnerable › Vulnerabilities

CVE-2021-41816

Description

CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.

Affected products

How to fix

Upgrade to a fixed version: ruby-lang CGI 0.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-41816 or the next vulnerability affects your stack