What’s Vulnerable › Vulnerabilities
CVE-2021-41817
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-01 · updated 2026-06-17
- Weakness: CWE-1333
Description
Date.parse in the date gem through 3.2.0 for Ruby allows ReDoS (regular expression Denial of Service) via a long string. The fixed versions are 3.2.1, 3.1.2, 3.0.2, and 2.0.1.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 34, 35
- openSUSE Factory: all versions
- openSUSE Leap: 15.2
- Red Hat Enterprise Linux: 7.0, 8.0
- RedHat Software Collections: all versions
- ruby-lang Date: before 2.0.1; from 3.0.0 before 3.0.2; from 3.1.0 before 3.1.2; 3.2.0 — fixed in 2.0.1, 3.0.2, 3.1.2
- Ruby: from 2.6.0 before 2.6.9; from 2.7.0 before 2.7.5; from 3.0.0 before 3.0.3 — fixed in 2.6.9, 2.7.5, 3.0.3
- SUSE Linux Enterprise: 12.0, 15.0
How to fix
Upgrade to a fixed version: ruby-lang Date 2.0.1, 3.0.2, 3.1.2; Ruby 2.6.9, 2.7.5, 3.0.3. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/1254844
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IUXQCH6FRKANCVZO2Q7D2SQX33FP3KWN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UTOJGS5IEFDK3UOO7IY4OTTFGHGLSWZF/
- https://security.gentoo.org/glsa/202401-27
- https://www.ruby-lang.org/en/news/2021/11/15/date-parsing-method-regexp-dos-cve-2021-41817/
- https://hackerone.com/reports/1254844
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IUXQCH6FRKANCVZO2Q7D2SQX33FP3KWN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UTOJGS5IEFDK3UOO7IY4OTTFGHGLSWZF/
- https://security.gentoo.org/glsa/202401-27
- https://www.ruby-lang.org/en/news/2021/11/15/date-parsing-method-regexp-dos-cve-2021-41817/
Get alerted when CVE-2021-41817 or the next vulnerability affects your stack