What’s Vulnerable › Vulnerabilities

CVE-2021-41819

Description

CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem through 0.3.0 for Ruby.

Affected products

How to fix

Upgrade to a fixed version: Ruby 2.7.5, 3.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-41819 or the next vulnerability affects your stack