What’s Vulnerable › Vulnerabilities
CVE-2021-41832: Content Manipulation with Certificate Validation Attack
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-11 · updated 2026-06-17
- Weakness: CWE-347
Description
It is possible for an attacker to manipulate documents to appear to be signed by a trusted source. All versions of Apache OpenOffice up to 4.1.10 are affected. Users are advised to update to version 4.1.11. See CVE-2021-25635 for the LibreOffice advisory.
Affected products
- Apache Software Foundation Apache OpenOffice: before 4.1.11 — fixed in 4.1.11
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OpenOffice 4.1.11. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/rd3214a568b43dd335b5d558f521377f4bff750684dea18eb041fc1bb%40%3Cusers.openoffice.apache.org%3E
- https://lists.apache.org/thread.html/rfbc93cd7cea40e2ad3b6e080f688dd02566cdd2b1984fcbb6f8b0fb6%40%3Cannounce.apache.org%3E
- https://lists.apache.org/thread.html/rd3214a568b43dd335b5d558f521377f4bff750684dea18eb041fc1bb%40%3Cusers.openoffice.apache.org%3E
- https://lists.apache.org/thread.html/rfbc93cd7cea40e2ad3b6e080f688dd02566cdd2b1984fcbb6f8b0fb6%40%3Cannounce.apache.org%3E
Get alerted when CVE-2021-41832 or the next vulnerability affects your stack