What’s Vulnerable › Vulnerabilities
CVE-2021-4191
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 80.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-28 · updated 2026-06-17
Description
An issue has been discovered in GitLab CE/EE affecting versions 13.0 to 14.6.5, 14.7 to 14.7.4, and 14.8 to 14.8.2. Private GitLab instances with restricted sign-ups may be vulnerable to user enumeration to unauthenticated users through the GraphQL API.
Affected products
- GitLab: from 13.0.0 before 14.6.5; from 14.7.0 before 14.7.4; from 14.8 before 14.8.2 — fixed in 14.6.5, 14.7.4, 14.8.2
How to fix
Upgrade to a fixed version: GitLab 14.6.5, 14.7.4, 14.8.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-4191.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/343898
- https://hackerone.com/reports/1089609
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-4191.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/343898
- https://hackerone.com/reports/1089609
Get alerted when CVE-2021-4191 or the next vulnerability affects your stack