What’s Vulnerable › Vulnerabilities
CVE-2021-4194: Improper Access Control in bookstackapp/bookstack
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-06 · updated 2026-06-17
- Weakness: CWE-284
Description
bookstack is vulnerable to Improper Access Control
Affected products
- bookstackapp/bookstack: before 21.12.1 — fixed in 21.12.1
How to fix
Upgrade to a fixed version: bookstackapp/bookstack 21.12.1. Check the vendor advisory for mitigations.
References
- https://github.com/bookstackapp/bookstack/commit/cb0d674a71449de883713db2fcdccb6e108992ad
- https://huntr.dev/bounties/0bc8b3f7-9057-4eb7-a989-24cd5689f114
- https://github.com/bookstackapp/bookstack/commit/cb0d674a71449de883713db2fcdccb6e108992ad
- https://huntr.dev/bounties/0bc8b3f7-9057-4eb7-a989-24cd5689f114
Get alerted when CVE-2021-4194 or the next vulnerability affects your stack