What’s Vulnerable › Vulnerabilities
CVE-2021-41973: Apache MINA HTTP listener DOS
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-835
Description
In Apache MINA, a specifically crafted, malformed HTTP request may cause the HTTP Header decoder to loop indefinitely. The decoder assumed that the HTTP Header begins at the beginning of the buffer and loops if there is more data than expected. Please update MINA to 2.1.5 or greater.
Affected products
- Apache Software Foundation Apache MINA: before 2.0.22; from 2.1.0 before 2.1.5 — fixed in 2.0.22, 2.1.5
- Oracle Corporation Banking Payments: 14.5
- Oracle Corporation Oracle Banking Trade Finance Process Management: 14.5
- Oracle Corporation Banking Treasury Management: 14.5
- Oracle Communications Cloud Native Core Console: 1.9.0
- Oracle Customer Management And Segmentation Foundation: 18.0, 19.0
- Oracle Corporation FLEXCUBE Universal Banking: from 14.0 through 14.3; 14.5
- Oracle Fusion Middleware Common Libraries And Tools: 12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0
- Oracle Corporation OSS Support Tools: 2.12.42
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache MINA 2.0.22, 2.1.5. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/11/01/2
- http://www.openwall.com/lists/oss-security/2021/11/01/8
- https://lists.apache.org/thread.html/r0b907da9340d5ff4e6c1a4798ef4e79700a668657f27cca8a39e9250%40%3Cdev.mina.apache.org%3E
- https://www.oracle.com/security-alerts/cpuapr2022.html
- http://www.openwall.com/lists/oss-security/2021/11/01/2
- http://www.openwall.com/lists/oss-security/2021/11/01/8
- https://lists.apache.org/thread.html/r0b907da9340d5ff4e6c1a4798ef4e79700a668657f27cca8a39e9250%40%3Cdev.mina.apache.org%3E
- https://www.oracle.com/security-alerts/cpuapr2022.html
Get alerted when CVE-2021-41973 or the next vulnerability affects your stack