What’s Vulnerable › Vulnerabilities
CVE-2021-42001: PingID Desktop encryption libraries misconfiguration can lead to sensitive data exposure
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-30 · updated 2026-06-17
- Weakness: CWE-310
Description
PingID Desktop prior to 1.7.3 has a misconfiguration in the encryption libraries which can lead to sensitive data exposure. An attacker capable of exploiting this vulnerability may be able to successfully complete an MFA challenge via OTP.
Affected products
- Ping Identity PingID Desktop: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: Ping Identity PingID Desktop 1.7.3. Check the vendor advisory for mitigations.
References
- https://docs.pingidentity.com/bundle/pingid/page/dyt1645545885978.html
- https://www.pingidentity.com/en/resources/downloads/pingid.html
- https://docs.pingidentity.com/bundle/pingid/page/dyt1645545885978.html
- https://www.pingidentity.com/en/resources/downloads/pingid.html
Get alerted when CVE-2021-42001 or the next vulnerability affects your stack