What’s Vulnerable › Vulnerabilities
CVE-2021-42008
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-05 · updated 2026-06-17
- Weakness: CWE-787
Description
The decode_data function in drivers/net/hamradio/6pack.c in the Linux kernel before 5.13.13 has a slab out-of-bounds write. Input from a process that has the CAP_NET_ADMIN capability can lead to root access.
Affected products
- Debian Linux: 9.0
- Linux kernel: from 2.6.12 before 4.4.282; from 4.5 before 4.9.281; from 4.10 before 4.14.245; from 4.15 before 4.19.205; from 4.20 before 5.4.143; from 5.5 before 5.10.61 — fixed in 4.14.245, 4.19.205, 4.4.282, 4.9.281, 5.10.61, 5.13.13
- NetApp H300E Firmware: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500E Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700E Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp Solidfire Baseboard Management Controller Firmware: all versions
How to fix
Upgrade to a fixed version: Linux kernel 4.14.245, 4.19.205, 4.4.282, 4.9.281. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.13.13
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=19d1532a187669ce86d5a2696eb7275310070793
- https://lists.debian.org/debian-lts-announce/2021/12/msg00012.html
- https://security.netapp.com/advisory/ntap-20211104-0002/
- https://www.youtube.com/watch?v=d5f9xLK8Vhw
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.13.13
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=19d1532a187669ce86d5a2696eb7275310070793
- https://lists.debian.org/debian-lts-announce/2021/12/msg00012.html
- https://security.netapp.com/advisory/ntap-20211104-0002/
- https://www.youtube.com/watch?v=d5f9xLK8Vhw
Get alerted when CVE-2021-42008 or the next vulnerability affects your stack