What’s Vulnerable › Vulnerabilities
CVE-2021-4202
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-25 · updated 2026-06-17
- Weakness: CWE-362
Description
A use-after-free flaw was found in nci_request in net/nfc/nci/core.c in NFC Controller Interface (NCI) in the Linux kernel. This flaw could allow a local attacker with user privileges to cause a data race problem while the device is getting removed, leading to a privilege escalation problem.
Affected products
- Linux kernel: from 3.2 before 4.4.294; from 4.5 before 4.9.292; from 4.10 before 4.14.257; from 4.15 before 4.19.219; from 4.20 before 5.4.163; from 5.5.0 before 5.10.82 — fixed in 4.14.257, 4.19.219, 4.4.294, 4.9.292, 5.10.82, 5.15.5
How to fix
Upgrade to a fixed version: Linux kernel 4.14.257, 4.19.219, 4.4.294, 4.9.292. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/06/01/2
- http://www.openwall.com/lists/oss-security/2022/06/04/2
- http://www.openwall.com/lists/oss-security/2022/06/07/2
- https://bugzilla.redhat.com/show_bug.cgi?id=2036682
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=3e3b5dfcd16a3e254aab61bd1e8c417dd4503102
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=48b71a9e66c2eab60564b1b1c85f4928ed04e406
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=86cdf8e38792545161dbe3350a7eced558ba4d15
- https://security.netapp.com/advisory/ntap-20220513-0002/
- http://www.openwall.com/lists/oss-security/2022/06/01/2
- http://www.openwall.com/lists/oss-security/2022/06/04/2
- http://www.openwall.com/lists/oss-security/2022/06/07/2
- https://bugzilla.redhat.com/show_bug.cgi?id=2036682
Get alerted when CVE-2021-4202 or the next vulnerability affects your stack