What’s Vulnerable › Vulnerabilities
CVE-2021-4204
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-24 · updated 2026-06-17
- Weakness: CWE-20
Description
An out-of-bounds (OOB) memory access flaw was found in the Linux kernel's eBPF due to an Improper Input Validation. This flaw allows a local attacker with a special privilege to crash the system or leak internal information.
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.8.0; 5.8.0 — fixed in 5.8.0
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
- Red Hat Enterprise Linux: 9.0
How to fix
Upgrade to a fixed version: Linux kernel 5.8.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2021-4204
- https://bugzilla.redhat.com/show_bug.cgi?id=2039178
- https://security-tracker.debian.org/tracker/CVE-2021-4204
- https://security.netapp.com/advisory/ntap-20221228-0003/
- https://www.openwall.com/lists/oss-security/2022/01/11/4
- https://access.redhat.com/security/cve/CVE-2021-4204
- https://bugzilla.redhat.com/show_bug.cgi?id=2039178
- https://security-tracker.debian.org/tracker/CVE-2021-4204
- https://security.netapp.com/advisory/ntap-20221228-0003/
- https://www.openwall.com/lists/oss-security/2022/01/11/4
Get alerted when CVE-2021-4204 or the next vulnerability affects your stack