What’s Vulnerable › Vulnerabilities
CVE-2021-42050
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-14 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in AbanteCart before 1.3.2. It allows DOM Based XSS.
Affected products
- AbanteCart: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: AbanteCart 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/abantecart/abantecart-src/releases
- https://sec-consult.com/vulnerability-lab/advisory/multiple-vulnerabilities-in-abantecart-e-commerce-platform/
- https://github.com/abantecart/abantecart-src/releases
- https://sec-consult.com/vulnerability-lab/advisory/multiple-vulnerabilities-in-abantecart-e-commerce-platform/
Get alerted when CVE-2021-42050 or the next vulnerability affects your stack