What’s Vulnerable › Vulnerabilities
CVE-2021-4206
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-29 · updated 2026-06-17
- Weakness: CWE-190
Description
A flaw was found in the QXL display device emulation in QEMU. An integer overflow in the cursor_alloc() function can lead to the allocation of a small cursor object followed by a subsequent heap-based buffer overflow. This flaw allows a malicious privileged guest user to crash the QEMU process on the host or potentially execute arbitrary code within the context of the QEMU process.
Affected products
- Debian Linux: 10.0, 11.0
- QEMU: before 7.0.0 — fixed in 7.0.0
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: QEMU 7.0.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2036998
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://security.gentoo.org/glsa/202208-27
- https://starlabs.sg/advisories/21-4206/
- https://www.debian.org/security/2022/dsa-5133
- https://bugzilla.redhat.com/show_bug.cgi?id=2036998
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://security.gentoo.org/glsa/202208-27
- https://security.netapp.com/advisory/ntap-20250321-0010/
- https://starlabs.sg/advisories/21-4206/
- https://www.debian.org/security/2022/dsa-5133
Get alerted when CVE-2021-4206 or the next vulnerability affects your stack