What’s Vulnerable › Vulnerabilities
CVE-2021-42097
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-21 · updated 2026-06-17
- Weakness: CWE-352
Description
GNU Mailman before 2.1.35 may allow remote Privilege Escalation. A csrf_token value is not specific to a single user account. An attacker can obtain a value within the context of an unprivileged user account, and then use that value in a CSRF attack against an admin (e.g., for account takeover).
Affected products
- Debian Linux: 10.0
- GNU Mailman: before 2.1.35 — fixed in 2.1.35
How to fix
Upgrade to a fixed version: GNU Mailman 2.1.35. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/10/21/4
- https://bugs.launchpad.net/mailman/+bug/1947640
- https://mail.python.org/archives/list/mailman-announce%40python.org/thread/IKCO6JU755AP5G5TKMBJL6IEZQTTNPDQ/
- https://www.debian.org/security/2021/dsa-4991
- http://www.openwall.com/lists/oss-security/2021/10/21/4
- https://bugs.launchpad.net/mailman/+bug/1947640
- https://mail.python.org/archives/list/mailman-announce%40python.org/thread/IKCO6JU755AP5G5TKMBJL6IEZQTTNPDQ/
- https://www.debian.org/security/2021/dsa-4991
Get alerted when CVE-2021-42097 or the next vulnerability affects your stack