What’s Vulnerable › Vulnerabilities
CVE-2021-4213
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-24 · updated 2026-06-17
- Weakness: CWE-401
Description
A flaw was found in JSS, where it did not properly free up all memory. Over time, the wasted memory builds up in the server memory, saturating the server’s RAM. This flaw allows an attacker to force the invocation of an out-of-memory process, causing a denial of service.
Affected products
- Debian Linux: 10.0, 11.0
- Dogtagpki Network Security Services For Java: before 4.9.3; from 5.0.0 before 5.1.0 — fixed in 4.9.3, 5.1.0
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: Dogtagpki Network Security Services For Java 4.9.3, 5.1.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2021-4213
- https://bugzilla.redhat.com/show_bug.cgi?id=2042900
- https://github.com/dogtagpki/jss/commit/3aabe0e9d59b0a42e68ac8cd0468f9c5179967d2
- https://github.com/dogtagpki/jss/commit/5922560a78d0dee61af8a33cc9cfbf4cfa291448
- https://security-tracker.debian.org/tracker/CVE-2021-4213
- https://access.redhat.com/security/cve/CVE-2021-4213
- https://bugzilla.redhat.com/show_bug.cgi?id=2042900
- https://github.com/dogtagpki/jss/commit/3aabe0e9d59b0a42e68ac8cd0468f9c5179967d2
- https://github.com/dogtagpki/jss/commit/5922560a78d0dee61af8a33cc9cfbf4cfa291448
- https://security-tracker.debian.org/tracker/CVE-2021-4213
Get alerted when CVE-2021-4213 or the next vulnerability affects your stack