What’s Vulnerable › Vulnerabilities
CVE-2021-42139
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-11 · updated 2026-06-17
- Weakness: CWE-94
Description
Deno Standard Modules before 0.107.0 allows Code Injection via an untrusted YAML file in certain configurations.
Affected products
- Deno Standard Modules: before 0.107.0 — fixed in 0.107.0
How to fix
Upgrade to a fixed version: Deno Standard Modules 0.107.0. Check the vendor advisory for mitigations.
References
- https://github.com/denoland/deno_std/pull/1275
- https://github.com/denoland/deno_std/releases/tag/0.107.0
- https://vuln.ryotak.me/advisories/58
- https://github.com/denoland/deno_std/pull/1275
- https://github.com/denoland/deno_std/releases/tag/0.107.0
- https://vuln.ryotak.me/advisories/58
Get alerted when CVE-2021-42139 or the next vulnerability affects your stack