What’s Vulnerable › Vulnerabilities
CVE-2021-4219
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-23 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in ImageMagick. The vulnerability occurs due to improper use of open functions and leads to a denial of service. This flaw allows an attacker to crash the system.
Affected products
- ImageMagick: before 6.9.12-9; from 7.1.0-0 before 7.1.0-19 — fixed in 6.9.12-9, 7.1.0-19
How to fix
Upgrade to a fixed version: ImageMagick 6.9.12-9, 7.1.0-19. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2054611
- https://bugzilla.redhat.com/show_bug.cgi?id=2054611
Get alerted when CVE-2021-4219 or the next vulnerability affects your stack