What’s Vulnerable › Vulnerabilities
CVE-2021-4222: WP Paginate < 2.1.4 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP-Paginate WordPress plugin before 2.1.4 does not sanitise and escape its preset settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Affected products
- WP-Paginate: before 2.1.4 — fixed in 2.1.4
How to fix
Upgrade to a fixed version: WP-Paginate 2.1.4. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/160800/
- https://wpscan.com/vulnerability/6df5f5b1-f10b-488e-80b3-2c024bbb8c78
- https://packetstormsecurity.com/files/160800/
- https://wpscan.com/vulnerability/6df5f5b1-f10b-488e-80b3-2c024bbb8c78
Get alerted when CVE-2021-4222 or the next vulnerability affects your stack