What’s Vulnerable › Vulnerabilities
CVE-2021-42220
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-15 · updated 2026-06-17
- Weakness: CWE-79
Description
A Cross Site Scripting (XSS) vulnerability exists in Dolibarr before 14.0.3 via the ticket creation flow. Exploitation requires that an admin copies the payload into a box.
Affected products
- Dolibarr: before 14.0.3 — fixed in 14.0.3
How to fix
Upgrade to a fixed version: Dolibarr 14.0.3. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/164544/Dolibarr-ERP-CRM-14.0.2-Cross-Site-Scripting-Privilege-Escalation.html
- https://truedigitalsecurity.com/advisory-summary-2021
- https://packetstormsecurity.com/files/164544/Dolibarr-ERP-CRM-14.0.2-Cross-Site-Scripting-Privilege-Escalation.html
- https://truedigitalsecurity.com/advisory-summary-2021
Get alerted when CVE-2021-42220 or the next vulnerability affects your stack