What’s Vulnerable › Vulnerabilities

CVE-2021-4231: Angular Comment cross site scripting

Description

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.

Affected products

How to fix

Upgrade to a fixed version: angularjs 11.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-4231 or the next vulnerability affects your stack