What’s Vulnerable › Vulnerabilities
CVE-2021-42546: Reflected XSS in search functionality of WP Cloud Plugins - Use-Your-Drive
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Insufficient Input Validation in the search functionality of Wordpress plugin Use-Your-Drive prior to 1.18.3 allows unauthenticated user to craft a reflected Cross-Site Scripting attack.
Affected products
- WP Cloud Plugins Use-Your-Drive: before 1.18.3 — fixed in 1.18.3
How to fix
Upgrade to a fixed version: WP Cloud Plugins Use-Your-Drive 1.18.3. Check the vendor advisory for mitigations.
References
- https://www.wpcloudplugins.com/wp-content/plugins/use-your-drive/_documentation/index.html#releasenotes
- https://www.wpcloudplugins.com/wp-content/plugins/use-your-drive/_documentation/index.html#releasenotes
Get alerted when CVE-2021-42546 or the next vulnerability affects your stack