What’s Vulnerable › Vulnerabilities
CVE-2021-42583
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-28 · updated 2026-06-17
- Weakness: CWE-327
Description
A Broken or Risky Cryptographic Algorithm exists in Max Mazurov Maddy before 0.5.2, which is an unnecessary risk that may result in the exposure of sensitive information.
Affected products
- foxcpp Maddy: before 0.5.2 — fixed in 0.5.2
How to fix
Upgrade to a fixed version: foxcpp Maddy 0.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/foxcpp/maddy/blob/df40dce1284cd0fd0a9e8e7894029553d653d0a5/internal/auth/shadow/verify.go
- https://github.com/foxcpp/maddy/releases/tag/v0.5.2
- https://github.com/foxcpp/maddy/blob/df40dce1284cd0fd0a9e8e7894029553d653d0a5/internal/auth/shadow/verify.go
- https://github.com/foxcpp/maddy/releases/tag/v0.5.2
Get alerted when CVE-2021-42583 or the next vulnerability affects your stack