What’s Vulnerable › Vulnerabilities
CVE-2021-4259: phpRedisAdmin login.inc.php authHttpDigest wrong operator in string comparison
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-19 · updated 2026-06-17
- Weakness: CWE-597
Description
A vulnerability was found in phpRedisAdmin up to 1.16.1. It has been classified as problematic. This affects the function authHttpDigest of the file includes/login.inc.php. The manipulation of the argument response leads to use of wrong operator in string comparison. Upgrading to version 1.16.2 is able to address this issue. The name of the patch is 31aa7661e6db6f4dffbf9a635817832a0a11c7d9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216267.
Affected products
- phpRedisAdmin: before 1.16.2 — fixed in 1.16.2
How to fix
Upgrade to a fixed version: phpRedisAdmin 1.16.2. Check the vendor advisory for mitigations.
References
- https://github.com/erikdubbelboer/phpRedisAdmin/commit/31aa7661e6db6f4dffbf9a635817832a0a11c7d9
- https://github.com/erikdubbelboer/phpRedisAdmin/releases/tag/v1.16.2
- https://vuldb.com/?id.216267
- https://github.com/erikdubbelboer/phpRedisAdmin/commit/31aa7661e6db6f4dffbf9a635817832a0a11c7d9
- https://github.com/erikdubbelboer/phpRedisAdmin/releases/tag/v1.16.2
- https://vuldb.com/?id.216267
Get alerted when CVE-2021-4259 or the next vulnerability affects your stack