What’s Vulnerable › Vulnerabilities
CVE-2021-42648
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted URL.
Affected products
- code-server: before 3.12.0 — fixed in 3.12.0
How to fix
Upgrade to a fixed version: code-server 3.12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-42648 or the next vulnerability affects your stack