What’s Vulnerable › Vulnerabilities
CVE-2021-42650
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS vulnerability exists in Portainer before 2.9.1 via the node input box in Custom Templates.
Affected products
- portainer: before 2.9.1 — fixed in 2.9.1
How to fix
Upgrade to a fixed version: portainer 2.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/portainer/portainer/pull/5766
- https://github.com/purple-WL/Security-vulnerability/blob/main/Portainer%20Custom%20Templates%20xss
- https://github.com/portainer/portainer/pull/5766
- https://github.com/purple-WL/Security-vulnerability/blob/main/Portainer%20Custom%20Templates%20xss
Get alerted when CVE-2021-42650 or the next vulnerability affects your stack