What’s Vulnerable › Vulnerabilities
CVE-2021-4268: phpRedisAdmin cross-site request forgery
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-21 · updated 2026-06-17
- Weakness: CWE-863
Description
A vulnerability, which was classified as problematic, was found in phpRedisAdmin up to 1.17.3. This affects an unknown part. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 1.18.0 is able to address this issue. The name of the patch is b9039adbb264c81333328faa9575ecf8e0d2be94. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216471.
Affected products
- phpRedisAdmin: before 1.18.0 — fixed in 1.18.0
How to fix
Upgrade to a fixed version: phpRedisAdmin 1.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/erikdubbelboer/phpRedisAdmin/commit/b9039adbb264c81333328faa9575ecf8e0d2be94
- https://github.com/erikdubbelboer/phpRedisAdmin/releases/tag/v1.18.0
- https://vuldb.com/?id.216471
- https://github.com/erikdubbelboer/phpRedisAdmin/commit/b9039adbb264c81333328faa9575ecf8e0d2be94
- https://github.com/erikdubbelboer/phpRedisAdmin/releases/tag/v1.18.0
- https://vuldb.com/?id.216471
Get alerted when CVE-2021-4268 or the next vulnerability affects your stack