What’s Vulnerable › Vulnerabilities
CVE-2021-42682
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-07 · updated 2026-06-17
- Weakness: CWE-190
Description
An Integer Overflow vulnerability exists in Accops HyWorks DVM Tools prior to v3.3.1.105 .The IOCTL Handler 0x22001B allows local attackers to execute arbitrary code in kernel mode or cause a denial of service (memory corruption and OS crash) via specially crafted I/O Request Packet.
Affected products
- Accops Hyworks Dvm Tools: before 3.3.1.105 — fixed in 3.3.1.105
How to fix
Upgrade to a fixed version: Accops Hyworks Dvm Tools 3.3.1.105. Check the vendor advisory for mitigations.
References
- https://www.sentinelone.com/labs/usb-over-ethernet-multiple-privilege-escalation-vulnerabilities-in-aws-and-other-major-cloud-services/
- https://www.sentinelone.com/labs/usb-over-ethernet-multiple-privilege-escalation-vulnerabilities-in-aws-and-other-major-cloud-services/
Get alerted when CVE-2021-42682 or the next vulnerability affects your stack