What’s Vulnerable › Vulnerabilities
CVE-2021-42717
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-07 · updated 2026-06-17
- Weakness: CWE-674
Description
ModSecurity 3.x through 3.0.5 mishandles excessively nested JSON objects. Crafted JSON objects with nesting tens-of-thousands deep could result in the web server being unable to service legitimate requests. Even a moderately large (e.g., 300KB) HTTP request can occupy one of the limited NGINX worker processes for minutes and consume almost all of the available CPU on the machine. Modsecurity 2 is similarly vulnerable: the affected versions include 2.8.0 through 2.9.4.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- F5 Nginx Modsecurity Waf: r24, r25
- Oracle Corporation Oracle HTTP Server: 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Oracle ZFS Storage Appliance Kit: 8.8
- owasp-modsecurity ModSecurity: from 3.0.0 before 3.0.6 — fixed in 3.0.6
- Trustwave Modsecurity: from 2.0.0 before 2.9.5 — fixed in 2.9.5
How to fix
Upgrade to a fixed version: owasp-modsecurity ModSecurity 3.0.6; Trustwave Modsecurity 2.9.5. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2022/05/msg00042.html
- https://www.debian.org/security/2021/dsa-5023
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.trustwave.com/en-us/resources/blogs/spiderlabs-blog/modsecurity-dos-vulnerability-in-json-parsing-cve-2021-42717/
- https://lists.debian.org/debian-lts-announce/2022/05/msg00042.html
- https://www.debian.org/security/2021/dsa-5023
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.trustwave.com/en-us/resources/blogs/spiderlabs-blog/modsecurity-dos-vulnerability-in-json-parsing-cve-2021-42717/
Get alerted when CVE-2021-42717 or the next vulnerability affects your stack