What’s Vulnerable › Vulnerabilities

CVE-2021-42756

Description

Multiple stack-based buffer overflow vulnerabilities [CWE-121] in the proxy daemon of FortiWeb 5.x all versions, 6.0.7 and below, 6.1.2 and below, 6.2.6 and below, 6.3.16 and below, 6.4 all versions may allow an unauthenticated remote attacker to achieve arbitrary code execution via specifically crafted HTTP requests.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiWeb 6.0.8, 6.1.3, 6.2.7, 6.3.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-42756 or the next vulnerability affects your stack