What’s Vulnerable › Vulnerabilities
CVE-2021-42770
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
A Cross-site scripting (XSS) vulnerability was discovered in OPNsense before 21.7.4 via the LDAP attribute return in the authentication tester.
Affected products
- OPNsense: through 19.7.0; from 21.7.0 before 21.7.4 — fixed in 21.7.4
How to fix
Upgrade to a fixed version: OPNsense 21.7.4. Check the vendor advisory for mitigations.
References
- https://cert.orange.com
- https://github.com/orangecertcc/security-research/security/advisories/GHSA-r32j-xgg3-w2rw
- https://opnsense.org/opnsense-21-7-4-released/
- https://cert.orange.com
- https://github.com/orangecertcc/security-research/security/advisories/GHSA-r32j-xgg3-w2rw
- https://opnsense.org/opnsense-21-7-4-released/
Get alerted when CVE-2021-42770 or the next vulnerability affects your stack