What’s Vulnerable › Vulnerabilities
CVE-2021-42771
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-20 · updated 2026-06-17
- Weakness: CWE-22
Description
Babel.Locale in Babel before 2.9.1 allows attackers to load arbitrary locale .dat files (containing serialized Python objects) via directory traversal, leading to code execution.
Affected products
- Debian Linux: 10.0
- Pocoo Babel: before 2.9.1 — fixed in 2.9.1
How to fix
Upgrade to a fixed version: Pocoo Babel 2.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/python-babel/babel/pull/782
- https://lists.debian.org/debian-lts-announce/2021/10/msg00018.html
- https://lists.debian.org/debian-lts/2021/10/msg00040.html
- https://www.debian.org/security/2021/dsa-5018
- https://www.tenable.com/security/research/tra-2021-14
- https://github.com/python-babel/babel/pull/782
- https://lists.debian.org/debian-lts-announce/2021/10/msg00018.html
- https://lists.debian.org/debian-lts/2021/10/msg00040.html
- https://www.debian.org/security/2021/dsa-5018
- https://www.tenable.com/security/research/tra-2021-14
Get alerted when CVE-2021-42771 or the next vulnerability affects your stack