What’s Vulnerable › Vulnerabilities
CVE-2021-42809: The Sentinel Protection Installer 7.7.0 does not properly restrict loading Dynamic Link Library
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-20 · updated 2026-06-17
- Weakness: CWE-913
Description
Improper Access Control of Dynamically-Managed Code Resources (DLL) in Thales Sentinel Protection Installer could allow the execution of arbitrary code.
Affected products
- Thales Sentinel Protection Installer: before 7.7.1 — fixed in 7.7.1
How to fix
Upgrade to a fixed version: Thales Sentinel Protection Installer 7.7.1. Check the vendor advisory for mitigations.
References
- https://cpl.thalesgroup.com/fr/software-monetization/security-updates
- https://cpl.thalesgroup.com/fr/software-monetization/security-updates
Get alerted when CVE-2021-42809 or the next vulnerability affects your stack