What’s Vulnerable › Vulnerabilities
CVE-2021-42833: Use of hardcoded credentials impacting AquaView versions 1.60, 7.x, 8.x
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-798
Description
A Use of Hardcoded Credentials vulnerability exists in AquaView versions 1.60, 7.x, and 8.x that could allow an authenticated local attacker to manipulate users and system settings.
Affected products
- Xylem Aquaview: from 7.0.0 before 8.0.1; 1.60 — fixed in 8.0.1
How to fix
Upgrade to a fixed version: Xylem Aquaview 8.0.1. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-350-01
- https://www.xylem.com/siteassets/about-xylem/cybersecurity/advisories/xpsa-aquaview-v5.0.pdf
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-350-01
- https://www.xylem.com/siteassets/about-xylem/cybersecurity/advisories/xpsa-aquaview-v5.0.pdf
Get alerted when CVE-2021-42833 or the next vulnerability affects your stack